Vscode的python插件突然无法识别import的解决方案

两百多天的家里蹲大学生活可算是告一段落了,然而一部大型灾难片即将上映!

《开學!》

由于疫情的原因,你校采用了封闭式管理措施。(这怎么能叫封闭式管理?学生可以进,教职工及其子女社会人员等可以进出。这样的灵活管理措施实在是太厉害🌶(

话不多说,直接进入正题

今天突然发现vscode的python intellisense插件显示不了import后面的包内容了。
而且好像是interpreter选择了>=python3.7的时候没法工作,用回python2.7就可以了。
上stackoverflow找到的回答以及官方文档中找到的解决方案,很多都只是说添加extra path中的包路径。我也这么照做了但好像并不怎么管用。

最终解决方案

这里我发现在安装了Python插件之后再安装Pylance插件就能完美工作了。